poj1724–dijkstra、优先队列
ROAD
Description
N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away – to the city N. He wants to get there as quickly as possible, but he is short on cash.We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away – to the city N. He wants to get there as quickly as possible, but he is short on cash.We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
Input
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.The third line contains the integer R, 1 <= R <= 10000, the total number of roads.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.The third line contains the integer R, 1 <= R <= 10000, the total number of roads.
Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
- S is the source city, 1 <= S <= N
- D is the destination city, 1 <= D <= N
- L is the road length, 1 <= L <= 100
- T is the toll (expressed in the number of coins), 0 <= T <=100
Notice that different roads may have the same source and destination cities.
Output
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
If such path does not exist, only number -1 should be written to the output.
Sample Input
5 6 7 1 2 2 3 2 4 3 3 3 4 2 4 1 3 4 1 4 6 2 1 3 5 2 0 5 4 3 2
Sample Output
11
思路:
先说下题意,题意第一行给了一个k,代表你有k的钱数,下一行有一个n,代表n个点,然后一个m,代表m条边,然后接下来m行,每行有四个数,分别代表起点、终点、路径长度和要花费的钱数,题目想问在花的钱不超过k的情况下,从1—n的最短路径是多少。
本题使用优先队列优化的dijkstra算法,用dis[i][j]表示从点1到点i时花费为j的最短距离,然后用优先队列时路径小的先出队。
代码:
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<stack>
#include<cstdio>
#include<map>
#include<set>
#include<string>
#include<queue>
using namespace std;
#define inf 0x3f3f3f3f
#define mem(x) memset(x,0,sizeof(x))
#define LL long long
int n,k,r,cnt=0;
int head[10005],dis[10005][10005];
struct star
{
int next,v,dis,cost;
}g[10005];
struct node
{
int num,dis,cost;
bool friend operator < (node a,node b){
return a.dis>b.dis;
}
};
void add_edge(int u,int v,int d,int c){
cnt++;//!!!
g[cnt].next=head[u];//!!!
g[cnt].v=v;
g[cnt].dis=d;
g[cnt].cost=c;
head[u]=cnt;//!!!
}
void dijkstra(){
for (int i = 1; i <= n ; ++i)
{
for (int j = 0; j <= k; ++j)
{
dis[i][j]=inf;//对于i点,从1到i,花费j元的最短距离
}
}
dis[1][0]=0;
priority_queue<node >q;
node now,to;
now.num=1;
now.dis=0;
now.cost=0;
q.push(now);
while(!q.empty()){
now=q.top();
q.pop();
if(now.num==n){
cout<<now.dis<<endl;
return ;
}
for(int i=head[now.num];i!=-1;i=g[i].next){
int cost=now.cost+g[i].cost;
if(cost>k) continue;
if(dis[g[i].v][cost]>now.dis+g[i].dis){
dis[g[i].v][cost]=now.dis+g[i].dis;
to.num=g[i].v;
to.cost=cost;
to.dis=dis[g[i].v][cost];
q.push(to);
}
}
}
cout<<"-1";
}
int main(int argc, char const *argv[])
{
cin>>k>>n>>r;
memset(head,-1,sizeof(head));
for (int i = 0; i < r; ++i)
{
int a,b,c,d;
cin>>a>>b>>c>>d;
add_edge(a,b,c,d);
}
dijkstra();
return 0;
}